8

I turned on History tracking for a custom object and set it to work on a particular field. When I updated the field on the custom object, I checked to see if the corresponding __History object had been created in Eclipse.

It had, but for whatever reason OldValue and NewValue appear to be blank. I am going to need this values in the code. Why are they null?

I thought it being a picklist might have had something to do with it, so I tracked the Owner field but that gave the same outcome.

enter image description here

5
  • 2
    This is a bug in the eclipse plugin, if you use another tool like workbench or SoqlX you'll see the real data.
    – superfell
    May 24 '13 at 21:36
  • @superfell can you mark this as answer so that this remains as a first hand info when working from eclipse plugin
    – Rao
    May 24 '13 at 21:42
  • Since the data is in the database, it looks like this is the correct answer. Is this in the known issues list?
    – George S.
    May 24 '13 at 21:42
  • 2
    Internally its bug W-1282412 (if you talk to support) i don't know if its on the known issues list.
    – superfell
    May 24 '13 at 22:20
  • Known Issues list entry success.salesforce.com/issues_view?id=a1p30000000SxYvAAK
    – superfell
    Jun 13 '13 at 3:05
9

This is a bug in the eclipse plugin, if you use another tool like workbench or SoqlX you'll see the real data.

2
  • 1
    FYI Workbench also isn't working at the moment.
    – Francis
    Sep 17 '14 at 14:40
  • It is only working from SF developer console now.
    – Kamal
    Dec 20 '19 at 6:58
4

It's worth noting too that OldValue and NewValue are both (genuinely) null in the History object when a record is locked and unlocked during an Approval Process, as well when it is created with null values.

0

1) Simple check : See for all the history records where newvalue!= null and oldvalue!=null (or) change a field on a record for which you are tracking history and try to isolate and see if the history is being tracked for that one record?

Are you seeing the changes being logged in the UI? (ie) when you go to any record change the field that you are tracking for the custom object and look at the history related list at the bottom do you see changes being tracked? enter image description here

In the system debug I queried the history related to the account where the name is being tracked.

list<accounthistory> acc_history = [select AccountId,oldvalue,newvalue,Isdeleted,Id,field,createddate,createdbyId from accounthistory where AccountId=:'001d000000wHSR9'];
for(accounthistory a: acc_history){
  system.debug('#### Newvalue'+ a.newvalue + '#### Oldvalue'+ a.oldvalue +'### created date:'+a.createddate);  
}

14:17:42.051 (51131000)|USER_DEBUG|[3]|DEBUG|#### Newvalue null#### Oldvalue null### created date:2013-04-06 01:41:34

14:17:42.051 (51496000)|USER_DEBUG|[3]|DEBUG|#### Newvalue Mechanical#### Oldvalue test 2### created date:2013-04-26 23:45:23

14:17:42.051 (51779000)|USER_DEBUG|[3]|DEBUG|#### Newvalue Mechanical_test#### Oldvalue Mechanical### created date:2013-05-24 21:07:02

14:27:41.051 (51826000)|USER_DEBUG|[3]|DEBUG|#### Newvalue No#### Oldvalue null### created date:2013-05-24 21:23:34

2
  • Hmm, in the Interface it's there, and also when I perform the query in the developer console. But why would it not be available in Eclipse? EDIT: just seen superfell's post, looks like a bug
    – George S.
    May 24 '13 at 21:40
  • @user227 see superfell's comment
    – Rao
    May 24 '13 at 21:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.