7

I get this error when deploying reports. Why?

Action: NO ACTION
Result: FAILED
Problem: filterlanguage: Invalid value specified: 1.

enter image description here

5
  • What are the filters for your report? A screenshot would be helpful. Commented May 24, 2013 at 13:07
  • added screenshot.
    – Ganesh
    Commented May 24, 2013 at 13:18
  • Are you deploying just that report? Or are there others? Commented May 24, 2013 at 13:19
  • There are a whole bunch of them. I am getting this very same error on most of the reports. Some are joined reports, some are simple tabular ones.
    – Ganesh
    Commented May 24, 2013 at 13:44
  • Amber, this is more a comment than an answer. Commented May 25, 2013 at 7:39

2 Answers 2

9

Filter Language isn't a normal filter but a special field in upper right corner in report editor.

report wizard in org with Translation Workbench

It's just a guess but please check whether you have Translation Workbench enabled (and same languages selected) in your source org but not in target org?

And if TW is enabled in both - is the language set on the report available in the target?

2
  • Thank you @eyescream. Translation workbench is enabled in Source org and is not enabled in the destination org. Also do you know if there would be issues if multicurrency status is different between the orgs? Currently it is enabled in source and might be turned off later. But can we deploy reports in the intermediate time when the status between the orgs is different. I will check the language settings and share my results.
    – Ganesh
    Commented May 26, 2013 at 9:15
  • 1
    login.salesforce.com/help/doc/en/… says you can't disable multicurrency mode once it's active (of course you could refresh & overwrite whole sandbox). I've never tried to do what you're doing... I think reports should be deployable as long as they don't have filter "amount > 100 EUR"
    – eyescream
    Commented May 26, 2013 at 10:42
1

This is for someone who is encountering this issue while creating 2 GP. Below are the 3 checks you need to check

  1. project-scratch-def.json : "language": "en_US"
  2. report folder: all the reports which use "language" attribute as "en_US" should be removed from the metadata
  3. Translation workbench must be enabled

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .