1

I am building 4 online submission forms that will create Orders__c in my org. This is my first exposure to creating new forms in Formsite, although I've had to adjust some in the past. I followed my predecessor's methods to pass the recordtypeID through a hidden field and cannot come to conclusion as to why it will not append properly in Salesforce.

  • I have full admin permissions in the org
  • The forms are linked through a different admin's sfdc account though he has a full admin account as well

In the picture:

  1. The mapping in Formsite's SF integration that displays that my hidden field is correctly mapped to ** Record Type ID
  2. The default value of the hidden field is correctly set to the desired record type ID
  3. The URL and ID of from the record type edit page

The order is submitted as it should but it is submitted using the wrong record type (used for numerous other forms via Formsite) 012A0000000zdrYwhereas desired: 012A00000012jVQ. Does anyone have experience with this issue or know of other possible avenues for investigating?

edit: I have tried both 15- and 18- character record type Ids

enter image description here

2
  • you telling that you need 4 online submission forms. Do you want 1 form for each recordtype ? May 2, 2016 at 18:39
  • That's correct @IlyaLepesh but I think I got it figured out, adding answer
    – JaredT
    May 2, 2016 at 18:47

1 Answer 1

1

It may have just been an artifact from the way I cloned and subsequently edited the forms but I've managed to solve the issue.

All I did was delete the hidden field and recreate it. The only actual change that occurred was the name of the field from recordtypeid to Record Type ID. The passed value was copied from the deleted field to the new one, so while I did not learn what the root cause was, the issue has been solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .