0

I have a few classes and matching test classes that Force.com says are deleted, but then counts those classes toward the test coverage minimum.

I changed the status of the classes to "Deleted" in the XML file in Eclipse and then deployed the changes. That should delete it, correct?

Here is an image to show you what I mean. This is the MySave class. As far as I can tell it should be gone. You'll notice there are two other Classes with zero coverage: scheduledCreateEventEngagements and scheduledCreateTaskEngagements. They have the same problem.

None of these classes show up in Salesforce when I view them in setup.

I have tried larger batches of deletes and they fail as well due to there supposedly not being enough code coverage.

Every other trigger and class in SF has 100% code coverage.

What am I missing?

  • I have refreshed the sandbox and then recreated the Eclipse project as well. Still no change. – Chance Apr 29 '16 at 18:48
1

It seems there is a reference elsewhere.

I used this website to find all references and I found out there was a VF page pulling the class.

I am sorry for the simple question, but I hope this helps others in the future.

| improve this answer | |
  • Also be sure to look at scheduled jobs as that may cause this same problem. – Chance Apr 29 '16 at 19:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.