Even though my data flow is successfully updated and shows by a green box and a tick mark. I am unable to see that file in the datasets. I have tried refreshing as well. What am I missing here?

3 Answers 3


Are you registering your dataset?

After all your extraction and transformation you have to register the last step in order to actually create the Dataset.

Make sure you have a node like this in your dataflow:

"Register_Dataset_Node": {
    "action": "sfdcRegister",
    "parameters": {
      "name": "Dataset Label",
      "alias": "Dataset_API_Name",
      "source": "name_of_your_last_node"

Hope this helps!

  • If you have registered and still not able to see the dataset.Then check if you have ran the dataflow and it should be successful.Then you should be able to see.

Maybe it's a replication issue? Did you check that?

If you have replication enabled, first you should go to 'Setup' under 'Data Manager' then run the replication on enabled Salesforce objects.

After that try running your 'Dataflow' again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .