1

I have created omni channel for leads and according to the criteria the created lead record is incoming to my omni-channel. But when i decline it , the records is gone off but again it is coming into the omni-channel. Please any of you tell to resolve this

1

Besides answer from @crmprogdev I want add one thing that's slightly my guess.

So I will start with the question: How many agents were connected to OmniChannel at the point of time when you were testing that functionality?

My guess here: you were the only one. And that's why you were receiving it again.

OmniChannel works on queues so the process is that Lead is added to the queue (because it needs an owner) and OmniChannel tries to pass to to ANYONE that's currently connected. And because you were the only one connected, even after declining you were re receiving it again.

How to "fix" that (well fix is not great word here, because everything works as expected)

You can use Busy presence status. (Setup -> Build->Customize->OmniChannel->Presence Statuses and Presence Configuration. There is great setup guide in documentation). So when you as an agent would not like to receive Leads anymore you can mark yourself as a busy person and OmniChannel won't route anything more for you.

Downside: Because OmniChannel works on assumption that agents should not decline specific record forever (because for example they don't like client or whatever) you can't resign from only one specific Lead.

enter image description here

| improve this answer | |
0

There are two ways to set up your routing with Omni-Channel. Under:

Setup > Customize > Omni-Channel > Routing Configurations | Edit: Routing Model

You should find the option to set your Routing Model to either Most Available or Least Active. These settings will affect how your records are assigned to your users.

You also need to configure Units of Capacity which relates to how many cases a user can handle at any given moment in time (you also have to set a unit of work which is typically one case, one email, one call, etc). Depending on your current settings, even if you decline a case, under your Routing Model, you may be assigned the same case again since no one else is available to accept it under your routing model and assignment rules.

If you set push time out status in presence configuration as below enter image description here

, and set particular time in routing configuration

enter image description here

then if you don't accept a case within a certain amount of time, it will be rerouted to the next available user that meets the Routing Model's Criteria. So, declining the case, may not be the best thing for your users to do with how you currently have it configured.

I recommend you adjust the settings I've just mentioned and test to see they help resolve your issues. This should at least point you in the right direction.

| improve this answer | |
  • Is it possible to list more than 1 records in the omni-channel. Even though i gave chat capacity as 3 , i am able to see only one record at a time – uma451 Apr 27 '16 at 6:18
  • Yes, you should be able to see 3, especially if a unit of work is 1. – crmprogdev Apr 27 '16 at 11:40
  • Thanks for your valuable comment!!Can u please tell what is unit of work? – uma451 Apr 27 '16 at 11:49
  • My apologies, I didn't use the correct term, it's unit of capacity. In your situation, that would be 1 chat. Each chat is a unit of capacity. A user becomes overloaded if they try to handle more than 3 chats at a time, correct? More than that and customers have long delays while waiting for responses and your users can get confused, etc trying to keep track of each conversation which defeats the purpose of Omni-channel. – crmprogdev Apr 27 '16 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.