1

I have this visualforce page below and I'm using the canvasApp, along with it I'm also passing the parameters but some reason I'm unable to see those parameters in the third party app what is it that I need to do in order to pass the parameters to canvasApp?

I'm aware that parameters are embedded in the context and when I debug the size of the parameters is showing 0

<apex:page >

    <apex:canvasApp developerName="CanvasMvcHelloWorld" 
         height="1000px" width="800px" 
        parameters="{vst_cli: '1293'}"/>

</apex:page>

Here is the screen shot:

enter image description here

2
  • How are you testing the Connected app ?Are you using previewer to test? Apr 27 '16 at 3:21
  • 1
    yes I'm using Canvas App Previewer to test it
    – Nick Kahn
    Apr 27 '16 at 3:22
1

The issue here is how you are testing the canvas App.Canvas App Previewer simply sends signed request and user context and not parameters from your actual visualforce page

Since the parameters are passed only when visualforce is rendered .You should test this via Visualforce page to see the parameters and not use canvas App previewer .

Go to your page URL salesforce_domain/apex/vfname

6
  • if i try to test through /apex/my_canvas_app then i'm getting this error Oops, there was an error rendering Force.com Canvas application [CanvasMvcHelloWorld]. Force.com Canvas can not locate an installed canvas app with the namespace [ttc] and API name [CanvasMvcHelloWorld]. what might invoke this error?
    – Nick Kahn
    Apr 27 '16 at 3:28
  • @NickKahn The problem you are now describing is totally different question .Check for developer name ?This means the developer name is incorrect and does not match . Apr 27 '16 at 3:30
  • 1
    hmmm i know i am getting totally different error now after trying directly going through apex/.... which i have not see this before... let me look
    – Nick Kahn
    Apr 27 '16 at 3:31
  • since i was not testing directly through VFP so I haven't see that error and the developerName was not correct thats why I was getting that above error... and now I can see my parameters thanks 1+
    – Nick Kahn
    Apr 27 '16 at 3:39
  • developerName=mycanvas_api_name
    – Nick Kahn
    Apr 27 '16 at 3:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.