5

I'm running into an issue with some of my flows where a Fast Lookup will not return any records, when I know for a fact there are items that meet the criteria.

I added a Wait statement to my flow, and after a few minutes it routes back to the lookup - often on the second try, it will succeed. (I added a counter variable so I only retry 3 times and then bail.) Nothing has changed in the underlying data - the records were always there - they just were not found the first time. Has anyone else experienced this?

Here is a log snippet which illustrates the problem. You'll see that the first lookup fails ("Failed to find records"), then a wait of one minute, then a success.

Thanks for any thoughts / suggestions.

FAST LOOKUP: Get_Opportunity Find all Opportunity records where: Custom_field__c Equals true AccountId Equals {!oli.AccountId} (00139000006Hm3tAAC) Assign those records to {!CurrentOpp}. Save these field values in the variable: Id Result Failed to find records.

Event Type: Alarm: Absolute Time Base Time = {!Flow.CurrentDateTime} (4/26/2016 3:23 PM) Offset Unit = Hours Offset Number = 0 Result Started waiting at 4/26/2016 3:23 PM.

The interview started waiting at 4/26/2016 3:23 PM. The interview was resumed at 4/26/2016 3:26 PM by Robb Allen (00429000000fq8t).

WAIT: Wait_for_1_minute Wait event Wait_for_1_minute_and_try_again occurred. The following values from the event were assigned to flow variables. {!Waittime} () = AlarmTime (4/26/2016 3:23 PM)

FAST LOOKUP: Get_Opportunity Find all Opportunity records where: Custom_field__c Equals true AccountId Equals {!oli.AccountId} (00139000006Hm3tAAC) Assign those records to {!CurrentOpp}. Save these field values in the variable: Id Result Successfully found records.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.