1

I have created a triggered send in Exacttarget which I am calling via APIs (SOAP and REST). While trying out the REST APIs I ran into two errors after which the triggered send has stopped processing emails. I see that the error count is 2 and the queued count is increasing but no emails are being sent.

  1. Firstly how and where can I see details of the errors while invoking the triggered send. I am unable to get any clue on this.
  2. How do I get the triggered send to start processing other calls? I have tried pausing and restarting. Also tried archiving and restarting but the queue is not being processed.

Any help is greatly appreciated. I am stuck on this point now for several hours.

1
  • Can you double check the subscriberkey, email and other variable columns are matching your trigger send DE fields? That error could occur if field names are not matched – Bo Hu Sep 6 '16 at 1:03
3

You'll have to contact SFMC Support to get the exact error that's causing your issues.

In the meantime, if you've configured your Triggered Send Definition to write to a Triggered Send templated Data Extension, you can do a Send Preview on your Email using that data to reveal any send-time errors. The Data Extension row is written before the email is triggered.

Pausing and starting is the way to get the queue processing again. It may take a few minutes. If you pause it, you can also view the queue and clear it.

0

Could you tell a bit more about how you construct your API call?

If your trigger send definition is based on Data Extension. it is likely you have wrong TriggerSendSubscriber attribute name, it needs to match data extension field name. Or you didn't specify TriggerSendSubscriber's SubscriberKey/Email attribute.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.