We have used oAuth in our manage package. This package have oAuth flow and it works fine for all client except one.

When we call /services/oauth2/userinfo it returns

404 (not found) — No_Access User lacks proper access to organization or information

We are using system admin user to connect and other API calls are working fine.

Any one have come across this issue?

The Help page also list this error but the cause of it. https://help.salesforce.com/HTViewHelpDoc?id=remoteaccess_using_userinfo_endpoint.htm


Ok, It turns out that the issue was due to generic URL https://test.salesforce.com/services/oauth2/userinfo

When we tried with using https://CS2.salesforce.com/services/oauth2/userinfo it worked just fine.

So, the point is we should always use the SERVER URL returned in login response to login API.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.