2

We have been using Territory Management 2.0 for about a year now. I was under the impression that when accounts are created or subsequently edited to meet the territory assignment rule criteria, the account would be assigned to the territory automatically. However, I must manually run the territory assignment rules in order to get the territory assigned to edited accounts.

Am I right in expecting that Salesforce should automatically assign territories to accounts when they meet the territory assignment rule criteria? Or, is it required to constantly run the assignment rules manually to keep accounts properly aligned to their territories?

If the rules must be manually ran, is there a way to schedule this step?

  • Which territory management are you using, the Enterprise 2.0 or the old one? – Jesse Milburn Apr 21 '16 at 16:12
  • Enterprise 2.0. I didn't realize that was a choice. – Swisher Sweet Apr 21 '16 at 17:44
  • I use the Enterprise 2.0 for one of our clients and it works how you describe it should, so not sure what your issue could be. – Jesse Milburn Apr 21 '16 at 19:59
1

As it turns out, one must set the Default checkbox on the account page layout properties if you want Salesforce to re-evaluate territory assignment rules when you edit an account:

enter image description here

By default, this checkbox is not checked (at least in our org). Checking this option and saving the page layout solved my problem.

As a side note, deploying the page layout results in the target org's Default setting becoming unchecked, regardless if it was checked in the source page layout. Salesforce support told me this was "expected behavior", although I can't imagine anyone wanting this "feature".

  • your post helped alot! Thanks! Please can you clear one confusion, When i enabled the checkbox on layout properties, the checkbox Evaluate this account against territory rules on save is visible on edit page but not with record creation. Why so? – Saumya Gaikwad May 11 '18 at 11:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.