I've come across an issue where Salesforce doesn't seem to be indexing records in a custom object that are created through the REST API. When searching for a record name or external ID no results are found in the global search. But, if I go to the record detail page and click "Edit" and Save the record without making any changes at all, it becomes searchable.

I've also verified that time doesn't seem to fix the issue either, in that even after 2 days the record is still not searchable until the process described above is gone through.

Has anyone else come across an issue like this? Any feedback would be greatly appreciated.

  • 1
    Interesting.. did you try creating the same record through any other API, to ensure it's REST-specific? Commented Apr 15, 2016 at 20:38
  • 5
    The documentation states that the delay before indexing is 15 mins or more. So SFDC doesn't give you a KPI on it. But 2 days is way out of line. This must be either a bug or a temporary hiccup (indexing queue filled up or something alike). If you can still replicate it, it might we worth logging a case with SFDC support to have them have a look. Commented Apr 16, 2016 at 16:11
  • 1
    How many records are there for the custom object. In particular, how many are you processing in the REST API request? Just an odd thought, could there be something odd about the character encoding of the values you are searching for? Then, something in the save process from the WEB UI is correcting it and getting it into the search index as expected. Commented Apr 19, 2016 at 1:56
  • 1
    Less than 1k total records at the moment. The REST API is only inserting one record at a time. Interesting thought about the odd character, I definitely have not noticed anything out the ordinary. Only way I can test that is to wait to have an issue with another record and take closer look at that point @DanielBallinger
    – jonnybro
    Commented Apr 19, 2016 at 7:36
  • 1
    @Marv-o sorry for not including the reference to the docs! Here is the page where the 15 mins are mentioned: help.salesforce.com/apex/… Commented Apr 19, 2016 at 9:01

1 Answer 1


see here it says 15 min or more and has other explanations too

  • If you read my initial question more closely you'll see that even after days of waiting, the record was still not searchable. Only after forcing an update to the record from the UI did it become searchable.
    – jonnybro
    Commented Jun 15, 2017 at 3:30
  • Then this can be an isolated performance issue. Do you have large data and complex sharing rule? Commented Jun 15, 2017 at 3:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .