9

I am trying to deploy a change set and even though I have received the email notifying me that it is ready, nothing appears in the target organization. This is after multiple successful uploads earlier today with the same users. Is there anything that could be causing this?

2 Answers 2

9

Sometimes it just takes a while before it shows up. It can sometimes take 20-30 minutes or more to even appear in the list. Even then it can take MORE time to actually be deployable.

If it's been more than an hour and you still don't see it then you may want to double check that you're deploying to the correct target organization.

5
  • 1
    I was under the impresion that once the email came through, it was ready Sep 5, 2012 at 19:53
  • 13
    That should be the case, but that isn't always how it works out. I use it as an excuse to take long lunches :) Sep 5, 2012 at 20:22
  • 2
    If it's been more than an hour and it's still missing, contact Salesforce Support. I had a changeset get "stuck" once, and needed their assistance to remove it from the queue. Sep 5, 2012 at 22:23
  • 4
    @Sdry: Obligitory XKCD reference Sep 6, 2012 at 15:34
  • @BobRoberts : Ha! didn't even need to open it to know which one it was going to be :D Sep 6, 2012 at 18:49
1

@Sdry A good one haha!

The availability of change sets in the target org can vary between 3 to 30 mins. Same goes with when deploying - deployment can go through in less than 5 mins or can take 45 minutes depending on the number of tests being run.

2
  • 1
    I've had a deploy take 1.5 hours to run, at 2am on AP1. It was a VERY large deployment. Dec 18, 2012 at 6:04
  • The deployments and uploads are both queued processes. So, if other clients on the same instance are deploying before you are, your deployment will generally take longer. A week back just an upload of a class took 4 hours for me!
    – subodhbahl
    Dec 19, 2012 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .