6

Thanks in advance,

I am sending an email from IBM Notes to Salesforce queue(Ex:test@test.com) with Subject line Chinese Character and the body content also Chinese character only. But after creating case, when i go and look into Salesforce the subject of the case is look like garbage characters "ÌÇ´×Àï¼¹/¹¬±£¼¦¶¡/ÂéÆŶ¹¸¯/âÆâ½/½È×Ó/³´Ãæ/±±¾©¿¾Ñ¼/´º¾í" but the body content remains same as chinese characters only not sure Why? this is going to create big issue from the customer side.

Note: i tried to send same email from other mailboxes like Gmail,Yahoo,hotmail and Outlook its working as expected there is no garbage characters in the subject line. this is very strange behavior i am finding but not sure whom i want to blame here either salesforce or IBM Notes.

this query i posted in salesforce discussion forum also but i didn't receive any reply. hope so some one can answer my question here.

1 Answer 1

2

It seems that there is a problem with the encoding. Go to Setup->Communication Templates->Click on the Email Template and check if it is set to UTF-8 for the email template.

Alternatively you need to check it from the User perspective as well so go to the User Detail page and check the Email Encoding field.

I hope this solves your issue!

5
  • Hi Marc, Thanks for your prompt response, in my setup Email Template: Encoding| General US & Western Europe (ISO-8859-1, ISO-LATIN-1) is available now, so do you want me to update to Unicode (UTF-8).
    – Sathish
    Apr 8, 2016 at 9:43
  • Yes try to update it to Unicode (UTF-8) and if it solved your issue choose my answer as the right one so that other people can view it if they encounter a similar problem. Apr 8, 2016 at 9:45
  • I tried but no luck my friend, here one thing we have to notify, when i send email from Gmail to salesforce queue (test@test.com) with Subject line chinese characters its showing chinese characters as it is but when i send email from IBM Notes (Lotus Notes) its showing garbage characters. if it is the Unicode setting issue than it should not work for the gmail and other mail boxes too. its strange behavior in salesforce, i would like to confirm this scenario from other users who were using IBM Notes so than we can figure out this is the issue from IBM Notes or Salesforce
    – Sathish
    Apr 8, 2016 at 9:52
  • did you try sending an email from IBM Notes to your gmail account? If in this case it's showing weird characters it seems to be a problem with the IBM Notes configuration and you should probably try to contact their support. Apr 8, 2016 at 9:56
  • ok, i setup my Queue with IBM Notes, and i sent an email from my mail box which i am using IBM Notes, than the problem is coming. if i sent email from Gmail to queue which i setup in IBM Notes than the issue is hitting here.
    – Sathish
    Apr 8, 2016 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.