1

Just installed, sublime and MavensMate and I am running Mavensmate from Linux, Fedora and I get this error when I try to open a new project

[MAVENSMATE]: response from mm: /bin/sh: /home/kova78/.config/sublime-text-3/Packages/User/MavensMate/mm/mm: cannot execute binary file

This directory "/User/MavensMate/mm/mm", doesn't exist on my disk. What creates this?

Could you please advise?

3
  • Are you using su to start sublime text?
    – abhi
    Commented Apr 5, 2016 at 17:50
  • Hi, Yes I dud. But I have an assumption that this error message "bash: ./mm: cannot execute binary file " comes when there is a platform compatibility issue. My Fedora20 is 32bit and I guess mm file is for 64 bit platform. Could this be? If yes, is there a 32 bits version? Thanks for the feedback.
    – kova78
    Commented Apr 5, 2016 at 18:00
  • From their guide http://mavensmate.com/Plugins/Sublime_Text/Installation Fedora doesn't seem to be official supported.
    – abhi
    Commented Apr 5, 2016 at 19:36

1 Answer 1

1

You need to configure a workspace:

Click MavensMate => Settings => User

Then assign a working directory to "mm_workspace"

enter image description here

3
  • Thank you for your answer but I think something else wrong here, that is what I get from the bash shell: [kova78@norad ~/.config/sublime-text-3/Packages/User/MavensMate/mm]$ ./mm bash: ./mm: cannot execute binary file Any clue?
    – kova78
    Commented Apr 5, 2016 at 14:14
  • Ok a bit confused, your question says when you try and open a new project. Are you not in the application trying to create a project? Commented Apr 5, 2016 at 14:17
  • 1
    I am in the application sublime 3 but when I click on "Mavensmate/Project New Project", nothing happens. Then I press CTRL + ` and I get the error message in the little console that I posted first. For some reason it cannot execute the file called nm. I went out to the bash shall and the file does exist and it also have execute permission too. Any idea?
    – kova78
    Commented Apr 5, 2016 at 14:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .