quick question-

So I'm doing a data migration right now, and I just did an export of the Task object. Most of the Task's are related to the Account object, but in the CSV file that I exported, the WhatId fields are populated with a random string '000000000000000AAA'. All of them have this string.

I've looked up a good bit of these records by hand, and they all have accounts that are on the actual Task record.

Is there anyway to correct this, or can someone tell me what I am doing wrong? It would be greatly appreciated, thanks!


2 Answers 2


This is what is referred to as the "Empty Key". It will be 15 0's followed by the 3 character suffix to make it case insensitive. They are used to represent null values in a Data Export. I've blogged about this in Salesforce Empty Key Id - 000000000000000AAA

Foreign keys that are empty typically point to the "Empty Key".
Benji Jasik, Senior Director Product Management

If you performed a SOQL query for those records in the developer console I'd expect the WhatId field would have an empty/null value.

  • Thanks for the link and info Daniel! Thats really unfortunate, is there anyway to tie these back to the account? You were right about it being black in the Dev Console So...interestingly enough, when I run a query on a record for the accountid it returns me an account that isn't actually on the Task record. When I export from Dataloader, I don't see this field anywhere as an option! Do you have any insight into this?
    – Christian
    Commented Mar 29, 2016 at 18:51
  • This helped. help.salesforce.com/apex/…
    – Christian
    Commented Mar 29, 2016 at 18:58
  • Still kinda doesn't make sense how its happening though. The process would most likely fall on the last listed on that link..that the what is null, so they look at the who id, which is populated. The Who Id(a contact) is associated directly with the correct account..however when I run the query it returns a completely different value for the accountid!
    – Christian
    Commented Mar 29, 2016 at 19:01

If anyone is still looking for this answer

A query on EntityDefinition will return two options for "id". Use the Durableid.

  • Wow, thank you for commenting. Yes, "DurableId" worked a charm. Commented Dec 13, 2022 at 16:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .