7

Using Google Chrome to edit Apex code / VF Pages in the Browser directly from test.salesforce.com. This has worked well for me (way better than the Developer Console or Eclipse - my programs are pretty small)

However, recently (Summer 13?) the line numbers displayed in the code editor window have disappeared - I can still edit the code, but both the line numbers, and the "Go To" (Control-G) functionality is now gone in Google Chrome.

They still work in Internet Explorer.

As far as I can tell, my Chrome is up-to-date...

Also, the Chrome editor is underlining the code, almost as if it's functioning like a Word Processor -

Is this a simple Chrome setting?

1
  • My dev Sandbox (on cs16) just got switched to Summer '13 today. Since the release was applied, line numbers are now missing from edit view when coding in the Firefox browser. The line numbers are still visible in Chrome and Safari. Jun 15 '13 at 23:28
2

In case anyone else runs across this...

For me, uninstalling and then re-installing Chrome fixed the problem (even though the same version was re-installed).

I still get a JS Console error - this time error 404 (Not Found) on the file "codeeditor.css", but otherwise the line #s and controls are back in Google Chrome and things seem to be working OK now....

1
  • 2
    Weird! Some caching issue maybe. Thanks for the heads up, we might be getting more of these as more orgs get promoted to Summer...
    – eyescream
    May 12 '13 at 12:25
0

Works for me? My Dev Edition is on Spring'13 and the Chrome version is "26.0.1410.64 m" (it claims to be up to date).

code edit window in Chrome

Check on http://trust.salesforce.com/trust/maintenance/ whether you're really on Summer'13. Did you opt in for a preview?

Have you installed recently any plugins? Maybe the JavaScript Console (Ctrl+Shift+J) reports errors? Can you try from another computer?

If you have no errors - try raising a case or posting to "Known Issues". There's only 1 filed for Summer'13 and I couldn't find anything that matches your problem.

1
  • 1
    thanks - I have the same chrome version, and my sandbox (cs9) was updated this morning to Summer 13 - Spring 12 works fine (production "edit" of VF Page), but Summer 13 does not. - the JS console shows "Uncaught ReferenceError: setAttr is not defined". Also tried this from a different computer - apologies if reply shows up several times - trying to edit the response I inadvertently hit the Enter key which appears to have (prematurely) sent the comment.... May 11 '13 at 23:06
0

I've got the same issue with Chrome 25. So I cleared all the caches from the beginning and it solve the problem. The line #s came back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.