2

I have a custom field that is referenced by an Approval process, long since deactivated. However when I try to delete the Approval process, I get:

Cannot Modify Active/Once Active Approval Process Definition Once an approval process has been activated, you cannot add or remove steps. Please create a new approval process from this one for modification. You may only delete an approval process that has no data records associated with it.

I did find some records by using Setup > Mass Transfer Approval Requests where I reassigned a bunch of approval requests to myself and then approved them (this is a test environment).

But it did not change the result - I still get the same error when trying to delete the approval process. Ideas?

3

The error is not due to the fact that the records were not approved, but the fact that records still exist in your environment that went through the process. Since it stores the history of the approval (and therefore the steps of the approval), it would require you to delete the records to sever that relationship. I believe the only way to resolve this would be to delete any record that has entered this approval process at one point or another.

Knowledge Article

Active approval processes can't be deleted. Before deleting an approval process, make sure it is inactive and that no records have been submitted for approval. If any records have been submitted, delete them and remove them from the Recycle Bin.


Please note, you must empty the recycle bin to allow this to happen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.