0

I recently upgraded to Force.com IDE v36. I have done this both on Kepler (4.3) and the latest Mars2 (4.5) versions of Eclipse. Setting aside my anger at the loss of a 1-click "run the test I'm looking at" context menu item.....I don't understand how to run a test. Can anyone please educate me, I've been at this over an hour. I set up a Run Configuration like the following:

Run configuration Common

Run configuration Test

and when I run it I get

Error

Update: today w/o any changes it runs and instead of the error I get a clean run, but no data (see attached). And yes I've tried this on tests w/o seeAllData set as well.

enter image description here

  • Dave - I feel your pain on the switcheroo for how tests are run in IDE V36. (1) Your setup looks fine; only thing I do differently is use @isTest annotation but your error looks more like the ToolingAPI's sobjects aren't built correctly. Are you using the released version 36 or the 'latest and greatest' from github? – cropredy Mar 12 '16 at 2:23
  • Thank you for the response. The reason you don't see the @isTest in the screenshots is only because its at the top of the class. I don't mix unit tests and code (actually I don't think its even possible to do that anymore). I've been writing SFDC apex code and unit tests for 5 yrs, so I don't think its the specific test/project structure. But to your point, I grabbed the plugin (v36) from the eclipse "add software" menu/dialogs. Are you saying I should perhaps grab a nightly build from git instead? I could try that and/or another fresh install of eclipse and the plugin. – Dave Mar 13 '16 at 19:54
  • No. I wouldn't use the latest build but I might rebuild the project by deleting the old one and recreating. – cropredy Mar 13 '16 at 19:58
  • You make a good point. I think this current project was "upgraded" via the upgrade dialog. I'll try your suggestion. Also see my update, the behavior changed today, which really feels like flakiness in the plugin (or the project build as you point out). I hope its that simple. Kinda frustrating. – Dave Mar 13 '16 at 20:04
  • I (still) feel your pain as I have analogous issues with IDE V36 (no debug logs returned when connected to my sandbox, works connected to DevEdition). Others will suggest using MavensMate - I find I keep Developer Console window open to inspect results for tests run in Eclipse. Your experience suggests that 'maintenance' is going on in the Tooling API for your pod – cropredy Mar 13 '16 at 21:48
0

It looks like the class you're trying to run isn't associated with the particular class that it tests. I can't tell from the screen capture if it's a utility class of some kind for configuring environments and/or creating objects perhaps (I do see that it has methods)? If so, it would be called from your test class and wouldn't run on it's own, or.. it would have it's own test class. It all would depend on how it's written.

What I also suspect is this: Normally from a PROJECT in the hierarchy, there would be a classes folder which would contain both the class you want to test and the test class. I don't see another class in your folder from the screen capture. If there is one that's only in your org, then you need to add it to your project. Once you do that, Eclipse should recognize it and associate it with your test class.

  • I think OP setup is fine as shown -- The class/method couldn't be selected in the Run Configurations if it wasn't a valid class/testmethod – cropredy Mar 12 '16 at 2:01
  • @crop1645 I was actually thinking his problem is more related to what I wrote in the 2nd paragraph, as in not having a clearly defined and structured project. But, as you know, it's very difficult to assess these things with limited info even though he did a great job of supplying screen shots. – crmprogdev Mar 12 '16 at 21:01
0

See comments above. Known issues w/ later versions of (34+) of plugin. I have reverted back to Force.com ide v33 running on Eclipse Mars2 and seems to be doing what I need. @cropredy thanks for the insight.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.