1

I received the following error while trying to sync my Salesforce for Outlook. Here is the stacktrace from the log:

2016-03-10 14:36:52,738 ERROR [Event] *********** Sync Engine *********** Error Exception code:INVALID_FIELD Sfdc.Server.SfdcServerInvalidFieldException: RecurrenceActivityId='00U1400000Zy3EREAZ' AND IsException = true ^ ERROR at Row:1:Column:88 No such column 'IsException' on entity 'Event'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names. ---> System.Web.Services.Protocols.SoapException: INVALID_FIELD: RecurrenceActivityId='00U1400000Zy3EREAZ' AND IsException = true ^ ERROR at Row:1:Column:88 No such column 'IsException' on entity 'Event'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names. at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) at Sfdc.Server.WebServiceHelper.InvokeCommon(Object serviceInstance, INVOKE_METHOD invoke, String methodName, Object[] parameters) at Sfdc.Server.Partner.SforceService.Invoke(String methodName, Object[] parameters) at Sfdc.Server.Partner.SforceService.query(String queryString) at Sfdc.Server.SfdcSession.Query(String queryString) --- End of inner exception stack trace --- at Sfdc.Server.SfdcSessionExceptionHelper.HandleException(Exception ex) at Sfdc.Server.SfdcSession.Query(String queryString) at Sfdc.Server.SfdcSyncConnector.UpdateExceptionsHistory(SfdcEvent item) at Sfdc.Server.SfdcSyncConnector.AcknowledgeItemsToHistoryWithoutTimestamp(SfdcHistoryDatabasePersistence history, IEnumerable1 items, Source source) at Sfdc.Server.SfdcSyncConnector.UpdateRecordsHistory(IList1 createdUpdatedItems, Source source) at Sfdc.Synchronization.EventSyncEngine.ApplyUpdatesToSfdcPostprocess(ConflictRecords conflicts, IList1 updatesToSfdcCudResults, IList1 updatesToSfdc, IList1 updatedItems, IList1 recreateItemsFromConflict) at Sfdc.Synchronization.SfoCommandSyncEngine.ApplyChangesToSfdc(IList1 createsFromOutlook, IList1 updatesFromOutlook, IList1 deletesFromOutlook, IList1 unmappedFromOutlook, ConflictRecords conflicts, MatchResults matchResults, Nullable1 changeWatermark) at Sfdc.Synchronization.SyncEngine.PerformSync(ChangedDataResult1 sfdcChanges, ChangedDataResult1 outlookChanges) at Sfdc.Synchronization.SyncEngine.Start()`

Please also take a look at the screenshot

enter image description here

Could you please advise what I need to do in order to solve the issue with my Salesforce for Outlook sync?

Regards,

Dilyan

  • Did you had this issue resolved? If so, how? – RajeshShah May 17 '16 at 12:13
2

The IsException field is from a feature called Advanced Calendaring. This feature is turned on by default in developer orgs, and is only available in Production orgs by logging a case.

If you've hooked your Salesforce for Outlook up to an org that has Advanced Calendaring and then hooked it up to your production org that doesn't have it, that might trigger this error. Also check the API version that you're connecting to with Salesforce for Outlook. If Advanced Calendaring is available in your org, it might only be available on API Version 36.0.

If you've switched which org it is hooked up to, you can reset it by deleting the DB folder located in .../AppData/Roaming/salesforce.com/Salesforce for Outlook/.

  • How do we find what is the API version Salesforce for outlook is running at? – RajeshShah May 17 '16 at 12:14
  • There's probably an easier way, but you can look in your log files under .../AppData/Roaming/salesforce.com/Salesforce for Outlook/logs/Trace.log. Look for "services/Soap/u/". You'll probably come across something like Logged into server using a refresh token: https://na24.salesforce.com/services/Soap/u/33.0. That means I'm on API version 33. – frontendloader May 17 '16 at 14:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.