0

I am using email service which is working fine for google and other although fails for yahoo. I have tried debugging but unable to capture anything inside the debug log. Although the case is been successfully created and the code is same from the past but the email service class unable to capture the yahoo.

Please let me know what could be the reason , I have tried setting the debug log but they are not working.Is the email service class fail for some reason.Also I am unable to capture the same in the debug log.

  • 1
    So you are saying that an inbound email from @yahoo.com fails to be received by your Apex Inbound Email Service? Note that the context user for the email service is the one where the debug log will be found - this may not be you – cropredy Mar 10 '16 at 3:35
  • @crop1645 I am unable to understand who can be the context user. Moreover when using email address of the email services things work fine but fails when using the routed email add that is else – cloudy-ritz Mar 10 '16 at 13:28
  • email from xxx@yahoo.com to your public alias myMailBox@myCompany.com will be forwarded to the SFDC inbound emailservice address (the very long one) by how you set up your forwarding rules in your company's mail system. It is possible that your forwarding rules simply reject all email coming from yahoo.com as an anti-spam measure – cropredy Mar 10 '16 at 19:55
  • It seems the issue is due to the following: success.salesforce.com/issues_view?id=a1p30000000T4BqAAK – cloudy-ritz Mar 10 '16 at 20:36
  • That known Issue is marked as Fixed; however, perhaps help.salesforce.com/HTViewSolution?id=000193813 – cropredy Mar 10 '16 at 20:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.