3

I am getting the following error when I deploy a page layout containing the related list of open activities.

Invalid field:TASK.SUBJECT in related list:RelatedActivityList

Now to get the deployment to pass, I needed to remove the XML part of the page layout that contains details for this related list. Why is this happening, isn't this a reference to a standard field? Any thoughts guys.

4
  • Just guessing may be current user dont have access to that field. Can you goto that field and check the security for current user profile ?
    – Ratan Paul
    Feb 29, 2016 at 6:34
  • If you are talking about the user that does deployment, that is the sys admin. So he has access
    – Prajith
    Feb 29, 2016 at 6:35
  • 1
    For what it's worth, I was just able to deploy a page layout to the Account object with a RelatedActivityList that contained the TASK.SUBJECT field.
    – martin
    Feb 29, 2016 at 7:27
  • My custom object already had <enableActivities>true</enableActivities> but like the answer from George S suggests, I had to toggle this false (push) then true again (push) before my layout would push
    – bkwdesign
    Oct 11, 2021 at 19:16

2 Answers 2

3

Perhaps this a bug - there is a VERY similar issue with a different related list Invalid field:SOLUTION.ISSUE in related list:RelatedSolutionList Error when deploying Case Page Layouts .

Since the issue is so similar and was so recently fixed, I think you should report this one as a bug.

1
  • Yeah I agree, I have ran into this issue being some what more popular than mine - while googling the error. Thanks Caspar
    – Prajith
    Feb 29, 2016 at 7:23
1

In my case, I was deploying a Custom Object with

<enableActivities>true</enableActivities>

omitted, and then redeploying with the layout and enableActivities set.

That should have worked, but failed due to this bug: https://trailblazer.salesforce.com/issues_view?id=a1p3A000000IXGkQAO&title=excluding-enableactivities-and-enablereports-settings-from-customobject-metadata-incorrectly-disables-the-settings-in-target-org

Adding enableActivities to the original deployment fixed it.

1
  • Between the accepted answer and this add'l answer I was able to get my source deployed for api 53 (winter 22)
    – bkwdesign
    Oct 11, 2021 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.