0

I have deactivated one the recordtype we have and I still see the option when I create a new case i.e. under 'Available cases record types' I deleted it without any issues and it just got rid of the name. I now see the id of the deleted recordtype.

Is there something I'm missing here to remove it from the available case record types?

enter image description here

  • Have you taken it off of available record types for the profile and emptied your recycle bin? – Jesse Milburn Feb 26 '16 at 19:21
  • Yes, emptied the recycle bin as well. Still no luck. – Kenn K Feb 26 '16 at 20:01
0

Go to setup => Manage Users => Profiles. Select the appropriate profile in question. Scroll down to Record Type Settings and edit the Cases record types. Remove it from the list on the right.

If you are on the newer view, Enhanced Profile User Interface, after selecting the profile select Object Settings and edit it there.

  • Did all that and it's not being removed. Weird thing is that it's being removed when I deactivate other record types. – Kenn K Feb 26 '16 at 20:00
  • @KennK I have a feeling that this will resolve itself in time when the SF "sweeper" removes the record from the table for good. Deleting a record from the recycle bin does not actually remove it from the table, it just marks to be removed by a SF process that constantly runs in the background. If you don't wish to wait for that (there is no guarantee on when this actually happens), I would open a support ticket to get that record manually purged by Salesforce support. – Jesse Milburn Feb 26 '16 at 21:23
  • @KennK That being said have you tried to query the Case records for where RecordTypeId = '01240000000DwAM', just to ensure that one didn't get missed in the mass update when deleting the record type? – Jesse Milburn Feb 26 '16 at 21:25
  • yes, I did run a query for all cases where recordtypeid = '01240000000DwAM' and got Zero. Thanks a lot for your help. – Kenn K Feb 27 '16 at 0:24
  • No prob at all, I think it is just a platform quirk, I have seen these a few times. Sorry my answer didn't help you. – Jesse Milburn Feb 27 '16 at 1:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.