1

I want to show custom link(visualforce page) on Home page available to only to specific group of people.I don't see an option to assign it via permission set.

4

You actually can do it via the $Permission global variable. Note the global variable checks if the running user has a Custom Permission, not a PermissionSetAssignment. Create a Visualforce Homepage Component as follows:

<apex:page standardStylesheets="false" showHeader="false" sidebar="false">
    <apex:outputLink rendered="{!$Permission.ShouldSeeHomepageLink}"
        value="{!$Page.HomepageLink}">{!$Label.HomepageLinkText}</apex:outputLink>
</apex:page>
4
  • Thank you,It works but for other users who doesn't have access to Custom Permission they see Visualforce page with the code
    – sfdc
    Feb 26 '16 at 16:07
  • @sfdc I don't understand what you're trying to convey.
    – Adrian Larson
    Feb 26 '16 at 16:09
  • Please check the update
    – sfdc
    Feb 26 '16 at 16:10
  • 1
    @sfdc It looks like the user you are testing with has Development Mode enabled. Disable it from their user record (there should be a Development Mode checkbox).
    – Adrian Larson
    Feb 26 '16 at 16:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.