29

When I save a change in my Force.com IDE this is not reflected on the server very often. I then have to manually use Force.com > Save to server.

I recently upgraded to Eclipse Juno but the problem remains.

Please note that I never turned "Build automatically" off. So this is not the reason for this misfunction. It only happens sometimes.

43

If you have "build automatically" option set, then whenever you save the file locally Eclipse will try and save it to the server.

Build Automatically menu option

Otherwise you have to explicitly use "Force | Save to server".

--edit-- Since you have the build automatically checked, it must be something else. Perhaps the org is locked at the time because of running tests? Have you looked at the Eclipse progress window? (you can add this to your view) When you hit save, this should be where you see the status of the save to server when build automatically is checked.

Progress window

What do you see now in your progress window if you try and save? Is there an error message?

edit2-- Another possibility is that you have somehow enabled "work offline" mode on your project. In this case it will still do the "save to server" on demand but not for normal saves even when build automatically is on. Work offline option

And when you select it you are warned Work offline warning

edit3-- One quick check to make would be to ensure that the classes are referenced in your package.xml Although, since you find it works when you manually "save to server" then this should not be the problem. Check this in Force.com | Add/remove Metadata Components and then ensure your class is listed there.

Other than that, can you try and pin down particular files that are affected? Is it a repeatable problem - try force "save to server" on a file. Then add a line or comment and do a normal save. Observe if the "polling server" progress appears. Check in the Problems window for anything like this Problems window showing sync state error

Once a file is out of sync you will need to resolve it and force save (this can happen if there is a problem communicating with the server or if someone else has updated the file and the instance copy is more up-to-date than your local one).

  • No errors at all. The UI behaves like in those cases where everything works. It's a bit faster but thats all... – Robert Sösemann Apr 30 '13 at 12:57
  • So, does it actually show the "polling to server" progress bar? How are you aware that it's not been saved to the server? Do you get the warning "File only saved locally, not to server"? – Doug B Apr 30 '13 at 13:11
  • 1
    I dont get that warning. Where should I see the Online Work menu? Its not in my context menu?! – Robert Sösemann Apr 30 '13 at 13:22
  • 4
    You need to right click on the Force.com project (not on a lower level like src) and you should get that option on the Force.com popout menu. – Doug B Apr 30 '13 at 14:01
  • 2
    Hey @DougB! Thank you very much for your extremely thorough answer. I was having the exact same problem, but once I followed your advice to re-enable "work online" mode, everything worked like a charm. Thanks!! – Vivek M. Chawla May 18 '13 at 1:08
20

It is really hard to notice, but when project is 'Online' you will notice a blue square background in the small X icon in the top left of the project root icon folder, and it missing in 'Offline' mode.

However, please note that if 'Menu: Project > Build Automatically' is unselected working online doesn’t seem to have any effect.

online-offline-icon-indicator-for-salesforce-eclipse-ide

You can take it online by Right click on project folder --> Force.com --> Work Online.

enter image description here

  • 1
    is this an answer or just a comment? if its an answer, can you add more details on why its offline and how to avoid that or bring it back online. – Vamsi Krishna Sep 16 '14 at 23:56
  • This is the only answer that worked for me. – Brian Oct 31 '14 at 19:37
  • OMG - Thank you! I have been 'Working Offline' for a while now without realizing it. FYI rather then Navigator use Project Explorer view: stackoverflow.com/questions/9991232/… – Daniel Sokolowski Jan 27 '15 at 17:51
0

Did you follow the instructions of Doug B. in Eclipse Juno or Helios? According to Salesforce you should be using Eclipse Helios as the most recent version of eclipse. Check it in http://wiki.developerforce.com/page/Force.com_IDE_Installation

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.