2

Hi i am tring to open reports chart in visualforce page but i am getting error:

this is me visualforce code:

<apex:page showheader="false">
<base target="_blank" />
        <analytics:reportChart reportId="report_id"  size="large" ></analytics:reportChart>
</apex:page>

The report chart is no longer available because the report has been moved to a personal folder. To display it, drag the report to a shared folder.

this only error how to solve this problem...

enter image description here

enter image description here

4
  • Check your report id....It needs to be valid. And ensure your report is saved into a public folder.
    – Richard N
    Feb 25 '16 at 6:31
  • This looks like accsssibility issue, trying to save in public folder or make sure to add in a folder for which running user is having complete access. Feb 25 '16 at 6:55
  • This is a permission issue. Don’t forget to save the report in a public folder (like Unfiled Reports). Give a shot again and let us know. Feb 25 '16 at 7:24
  • I Done the same process as per your suggestion . it is showing error message as per the below :- ** You can't view the report chart because its report, report type, or chart has been deleted**
    – user28833
    Feb 25 '16 at 7:28
1

Whenever you want to display a report chart in VisualForce page, the user should have appropriate permission to view the report as well.

Try the following:

  • Take the report_id and go the report page as 'https://mydomain.salesforce.com/[report_id]'

  • Edit the report and click on Save Properties

  • Make sure you save the report into accessible public folder (like Unfiled Reports)

Once you refresh the VF page you should be able to see the report.

Update:

  • The problem is you don't have any charts in the report to display

Add Chart:

  • Click on customize on the report and click on Add Chart
  • Save the report and come back here, you should be able to see the report

Its really weird that the message what it was displaying is mis-leading from what is really happening.

enter image description here

11
  • From your comment, it seems that your Admin or some other user delete the report. Contact your Admin for the same. You can try using some other report which you having access for testing purpose. Feb 25 '16 at 7:45
  • Sorry Ididn't understand first i need to tell what i did _i created one report with summary formate in my personal custom reports again i drag that report to unfilled public report then open that report i used that report id only used in visualforce page _
    – user28833
    Feb 25 '16 at 7:45
  • Take report_id and put it into your domain as 'your_domain.com/report_id' and tell me whats happening ? Feb 25 '16 at 7:47
  • Opening Marchandise Report page ...
    – user28833
    Feb 25 '16 at 7:53
  • Updated my report detail page and vf page screen shots can oyu please tell me where error occuring...
    – user28833
    Feb 25 '16 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy