4

Any idea how can I expose the Orders tab from Community Builder Napili Template?

I've got orders enabled, but I cannot find it from the list of objects when I'm adding a new Menu Item on the Navigation Menu component.

Navigation Menu Edit Screenshot

According to this link, Orders are available on Napili template, do I need to set something up first before the orders can be exposed?

UPDATE 23/02/ Ok I've tried @tobibeers comment and thought that it works. Yes, you can create a community object page using orders but it throws weird errors when trying to navigate through them.

Here's what i've done: 1. Create object page based on Order object.

Order Detail OrderDetail

Order List OrderList

  1. On the Navigation Menu component, add a Menu Item as a Community Page, then use the Order List page that was created. I've replaced the object and filterId parameter with "Order" and an order list view id respectively. Saved successfully. OrderNav

  2. Tried navigating to the orders tab. It shows the order list view that I've specified but a weird error pops up. TabErr

  3. Then I closed the pop-up, tried clicking on one of the order records from the list view. And this error comes up. OrderErr

Thought that creating that object page works, am I still missing something?

  • No idea what your problem is, but for me Orders are listed just fine. – tobibeer Feb 22 '16 at 11:52
  • Hey @tobibeer are you using the community builder with Napili template? – Sean Soriano Feb 22 '16 at 18:51
  • 1
    At least that's what I just tried in a dev org using the napili template. I went to > Setup > Customize > Communities > All Communities > Builder (link for the community) < ...and then clicked on > Pages Manager (left controls) > + (button) > Create Object Page < ...see imgur.com/COxZcHp – tobibeer Feb 22 '16 at 20:55
  • I've updated my post based on your suggestion. Creating the page works, but it has thrown weird errors around when trying to navigate through the orders page. – Sean Soriano Feb 22 '16 at 21:46
3

I just ran into this issue and it seems that the orders object is not supported in the Napili template

Supported Objects in Napili

This is mentioned in their Spring '16 release guides - https://resources.docs.salesforce.com/200/latest/en-us/sfdc/pdf/community_templates.pdf

  • Shucks, need to read the release notes more. Thanks for this! – Sean Soriano Feb 25 '16 at 22:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.