I am working on an integration using JSforce to query the Salesforce API for data. When I run a describe('object'), I get a list of fields that are contained within said object, including custom fields I had created a few months back. I went into my developer account, created a custom fields, made it visible to all, and saved this to the 'Campaign Layout'. When I ran the above request .describe('Campaign'), I got a list of all the fields, but not my newly created custom field.

I ran into this at the bottom of https://help.salesforce.com/HTViewHelpDoc?id=adding_fields.htm&language=en_US Salesforce create field note

Does this mean that the Salesforce database requires time before the API can return the updated list of fields? If so, how much time?

If this is not the case, does anyone have any suggestions as to why new fields are not showing up in an described object?

  • How long have you waited between the field creation and the describe call? I've never encountered any delay but it is theoretically possible. – Sebastian Kessel Feb 18 '16 at 16:03
  • Hey Sebastian Kessel, the modification time is listed as: 2/17/2016 3:23 PM and it is currently 2/18/2016 9:12 AM. 17 hours and 49 minutes? – Yuki Tokuda Feb 18 '16 at 16:14

Which version of the JSforce are you using. I faced a similar situation and after a couple of hours of struggle, I realised that I was using an older version v1.5.0. The moment I changed it to the most recent version i.e. v1.6.3 as of now, it worked like a charm. I was able to see my newly created custom fields. You can give it a try!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.