5

I am using the ANT Force.com Migration Tool to deploy a Lightning Community Builder based Community from our Dev Org to our Production Org. I have received various errors related to fields, apex classes, and more - which I have resolved through additional ChangeSet deployment.

However, I am stuck now with only 2 errors coming up in the Migration Tool:

All Component Failures:

1. sites/MSI_Community_v1.site -- Error: In field: Name - no Network named MSI Community v1 found

2. siteDotComSites/MSI_Community_v11.site -- Error: In field: Network - no Network named MSI Community v1 found

*********** DEPLOYMENT FAILED ***********

I've tried searching Google, as well as the Developer forums, but I am either using the wrong search terms or there isn't a lot of information available on this specific error. Both errors relate to some sort of Network, but I can't find anything related to 'Network' within any of the community or site settings in SFDC Setup. A global Setup search for Network didn't turn up any useful results either.

Does anyone know where this error stems from and how to resolve it? Your time is appreciated!

3

Have you tried importing the Network folder in the src .

Network is a metadata for communities .Your package xml will look like below

  <types>
    <members>*</members>
    <name>Network</name>
</types>

And you should be able to retrieve a Network folder which will have xml files for MSI community v1

| improve this answer | |
  • That did it, thanks! Unlocked a few MORE deployment errors once I got past this one, but thats a problem for another day :) Cheers! – Morgan Marchese Feb 7 '16 at 6:04
  • N.B. for other visitors here ... Regrettably, an alternative via the URL hack on Changesets by adding &entityType=Network to the end of the Add components Changeset URL, while bringing up the Network component for selection, does not allow it to be saved. – cropredy Mar 7 '17 at 17:07
3

When you create the community as a manual pre-deployment step (don't have to configure it other than define the name and select the template), you can deploy without needing to fetch Network and should not have any other deployment errors.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.