3

We're currently using a combination of Data Extensions, Data Extracts, and File Transfer activities to pull data out of Marketing Cloud and import these files into our own internal data warehouse.

One problem that we have noticed, is the "TextQualified" checkbox on a Data Extract activity just surrounds the whole text field in quotes, but doesn't first check whether there are any quotes inside the text field - causing import errors if there are.

We're working around this today with a really janky shell script which I'd love to get rid of - so I'm wondering if anyone knows of a way to correctly have quotes escaped when performing a data extract activity?

Cheers

  • 1
    I guess you use textqualified to avoid delimiting issues. Can't you omit the textqualified checkbox and use another delimiter? – Fred Feb 7 '16 at 7:17
  • Agree with @Fred. Use a stronger delimiter (pipe instead of comma, for example) and do not qualify text with quotes. – David Jackman Feb 12 '16 at 16:05
1

This is a fairly old post but we have come across the same issue where double quotes are not escaped inside the column value, eg:

"Hello " friend"

We managed to get around it by changing the data extract to an SQL Extract. Then in the SQL extract we simply replace double quotes with escaped double quotes for all necessary columns, eg:

REPLACE(BOUNCE_REASON, CHAR(34), CHAR(34)+CHAR(34))

 "Hello "" friend"

where CHAR(34) is the ascii code for a double quote.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.