1

After the January 2016 update was pushed out by ExactTarget, we can no longer get our JourneyBuilder Custom Activities to update.

When we go to "Activate" an interaction, we get a response that says:

1 errors. Resolve errors in the canvas before testing or activation.
Activity REST-1 of type REST has an argument execute which is not a valid argument

We haven't made any changes to our Custom Activity (v1.0 api), so I assume that this broke due to an ExactTarget change.

In our config, the arguments.execute property looks like this:

...
"execute": {
    "verb": "POST",
    "url": "https://example.com/notify",
    "body": "{}",
    "header": "",
    "format": "json",
    "useJwt": false,
    "timeout": 10000
},
...

Has anyone experienced this (and solved)?

7
  • Please can you provide URL to your config.json file? I think I may know what the issue is. – Eliot Harper Feb 2 '16 at 9:03
  • Our config.json is here: pfllink-dev-awrowse.azurewebsites.net/journeybuilder/… – Andy Rowse Feb 2 '16 at 17:05
  • can you try changing verb to method and header to headers and also remove the format name/value pair. – Eliot Harper Feb 2 '16 at 17:37
  • I think I've narrowed the issue down to my "body". If I include any sort of template values; i.e. {{Contact.Default.Email}} or {{Contact.ID}}, the interaction will fail to activate. The funny thing is that any interactions that I had previously activated still work and send the correctly resolved template data during the POST. @eliotharper, I see in some of your other posts you use inArguments with execute. Do those work for you? They should come across in the POST body, correct? – Andy Rowse Feb 3 '16 at 6:07
  • One more update. Looks like the issue with templated fields (ie. {{Contact.ID}}) isn't limited to the 'body' parameter. If I include this in an inArg we are not able to Activate the interaction. – Andy Rowse Feb 3 '16 at 6:25
1

I have confirmed (by testing) that this is fixed in the 19 March 2016 release.

When you published an Interaction that included a Custom Activity, previously you received the error:

Activity REST-1 of type REST has an argument execute which is not a valid argument and were unable to publish the Interaction.

Marketing Cloud acknowledged this bug and released a [long anticipated] fix for this issue in the March release.

I have successfully published an Interaction with a Custom Activity (and no longer receive the error) and the Interaction now appears to be working correctly; Contacts enter the Interaction and the Custom Activity functions as expected.

4
  • Can you add some more detail about how you verified? This answer does not really have enough content to be justified as being more than a comment, currently. – Adrian Larson Mar 20 '16 at 22:18
  • I meant you should edit this information into your answer. – Adrian Larson Mar 20 '16 at 22:48
  • I'm having exactly this same error working with the create case / update case example. "Activity REST-2 of type REST has an argument caseID which is not a valid argument" This was supposed to be fixed last 19 March 2016 release, but in my case is still failing. Do you have any idea why? – Sergio Andreu Jun 22 '16 at 9:33
  • Hello Sergio, this should work, please can you send a link to your config.json file? – Eliot Harper Jun 22 '16 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.