0

I'm currently trying to have my users on Salesforce1 edit records and upload pictures from their phone to the associated record. They currently have the edit button overridden to their custom visualforce page and I can't seem to get it to default back to the regular pages. I'm not sure if the overridden button is whats preventing the edit button from appearing on the layout.

I've also enabled publisher actions and salesforce1 actions on the layout with the file button their. For some reason I can't see the file button on the actions menu. Any idea why I can't edit or file upload. I have administrator access to the entire org.

  • So if I Understand correctly ,your publisher action button is not coming correctly ?Or its something else? – Mohith Shrivastava Jan 30 '16 at 1:29
  • Hi Mohith - See below with my response to tushar – DimlyAware Feb 1 '16 at 16:53
1

If i have understand your question correctly then your button is not coming in Salsforce one action bar.

You have missed the checkbox on Visualforce to enabe the page for salesforce one and lightning.

Go to Develop > Visualforce page > select your page and check the checkbox. it will solve the problem.

|improve this answer|||||
  • It does let me add other buttons like add note. I can also edit the fields that appear on the layout. It just won't let me add an edit button or attach file button. – DimlyAware Feb 1 '16 at 16:52
  • @DimlyAware did you enable the page for SF1? – Tushar Sharma Feb 2 '16 at 5:06
  • 1
    Hi Tushar, I found the problem. I didn't setup feed tracking. I thought I had. Thank you for helping me with this! – DimlyAware Feb 2 '16 at 13:41
-1

Just forgot to enable feed tracking

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.