1

I have turned on identity connect in production and turned off the ability for people to log in through any other means other than identity connect.

On refreshing my sandbox, I cannot login into my account.

Also, when trying the same using API, getting the error:

OLE DB provider "DBAmp.DBAmp" for linked server "SALESFORCE_TESTBOX" returned message "Error 1 : INVALID_SSO_GATEWAY_URL: the single sign on gateway url for the org is invalid".

I am using the similar login credentials to sandbox that I was using before refresh. Custom domain and Identity connect are not enabled in Sandbox.

I am really stuck here.

Any help on this will be appreciated!

Thanks!

  • Can anyone else log in? If not, Salesforce support is probably the only option – Jagular Jan 29 '16 at 21:47
3

When you refresh a sandbox, SSO settings are usually incorrect. After a refresh, you usually have to log in and fix those settings, and possibly fix the settings in Identity Connect as well. Fortunately, all is not lost. You can usually log in by appending ?login to your login URL. For example: https://mydomain.cs20.my.salesforce.com?login should allow you to log in, assuming that's your correct login URL. If that fails, you can contact support, and they can fix your Salesforce settings for you by disabling forced SSO logins.

| improve this answer | |
  • Thanks for this information. I do not have a custom domain. to login to. All I do is goto test.salesforce.com and login. Can we still get to work? – Salesforce Developer Jan 29 '16 at 22:09
  • @SalesforceDeveloper Simply using test.salesforce.com?login should also work. – sfdcfox Jan 29 '16 at 22:19
  • Thanks. The provided solution worked for me using the my domain. The My domain on refresh was copied to sandbox from Production environment. – Salesforce Developer Feb 1 '16 at 15:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.