2

I have a multi-select input field on my VF page, it is based on a field defined as mult-select in the custom object (Data Type is Picklist (Multi-Select)).

<td class="RightColumnTop W80" style="height:auto !important;">
    <div class="Mandatory">  
        <apex:inputField styleClass="MainPanelFont" 
            style="height:auto !important;width: auto !important;" 
            value="{!sObjectRFC.Benefits_Reasons__c }"/>
    </div>
</td>

In one page (Edit) the fields render correctly as two select lists with buttons in between:

enter image description here

but on another page, even though the code is the same they render without the buttons in between:

enter image description here

so what could be causing this on IE11, but we have the same issue on FireFox

any suggestions on how to resolve that?

At the top of our two pages we have this defined:

<meta http-equiv="X-UA-Compatible" content="IE=10" />
8
  • The fields are grayed out-- it appears they're read-only, which would imply that the UI is indeed correct. Perhaps it's a difference in user permissions?
    – sfdcfox
    Jan 29, 2016 at 17:44
  • @sfdcfox: no in fact that's the <styleClass="MainPanelFont"> setting the text color and font... no issues with user permissions either, as it allows me to double-click an item to choose it Jan 29, 2016 at 18:02
  • the second screen shot has the caption "(Double click an item to select it)" - is this a clue?
    – cropredy
    Jan 29, 2016 at 21:07
  • @crop1645: well, I've added that as a workaround for the users in case I cannot get it to render properly... right now I am seriously considering rebuilding the entire page from the ground up step by step to see what works... Jan 30, 2016 at 0:53
  • 1
    Try To Move The Left Box. Sometimes Box Hide The Buttons. I Have Also Face Same Issue. Jan 30, 2016 at 6:22

0

You must log in to answer this question.

Browse other questions tagged .