2

I can't get it work as it should.

The code rendered even for an empty page:

<apex:page standardStylesheets="false" standardController="Opportunity">

</apex:page>

Includes:

<link class="user" href="/sCSS/35.0/sprites/1450809186000/Theme3/default/gc/zen-componentsCompatible.css" rel="stylesheet" type="text/css" />
<link class="user" href="/sCSS/35.0/sprites/1450809186000/Theme3/default/gc/elements.css" rel="stylesheet" type="text/css" />
<link class="user" href="/sCSS/35.0/sprites/1450809186000/Theme3/default/gc/common.css" rel="stylesheet" type="text/css" />
<link class="user" href="/sCSS/35.0/sprites/1448894026000/Theme3/gc/dStandard.css" rel="stylesheet" type="text/css" />
<link class="user" href="/sCSS/35.0/sprites/1450809186000/Theme3/default/gc/extended.css" rel="stylesheet" type="text/css" />
<link class="user" href="https://fonts.googleapis.com/css?family=Source+Sans+Pro:400,200,300,600,700,900" rel="stylesheet" type="text/css" />
2
  • 1
    What if you try it with showheader="false"?
    – Phil B
    Commented Jan 26, 2016 at 20:58
  • 1
    Yes! It works! It should be documented somewhere ... I can accept it if you write answer. Thank you.
    – Shcheklein
    Commented Jan 26, 2016 at 21:11

1 Answer 1

3

According to Suppressing the Salesforce User Interface and Styles It will only work if you also disable the header by setting showheader="false".

standardStylesheets—Set to false, along with setting showHeader to false, to suppress the inclusion of the style sheets that support the Salesforce visual design. When you suppress the standard style sheets, your page is completely unstyled, except for your own style sheets.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .