1

I'm running into trouble getting Force IDE v35 to work with Eclipse Mars.1. Everything installs OK and I can create a Force.com project, but my package.xml file keeps reporting this error:

cvc-elt.1: Cannot find the declaration of element 'Package'.

I have uninstalled and reinstalled Eclipse and Force.com IDE plugins. Recreated the project multiple times. Still the same error. I have even replaced the entire computer and installed from scratch, and I still get the same error.

So, I downgraded to Kepler, and installed v35 of the Force IDE plugin and I get the same error. I've also verified the issues "crmprogdev" raised in his answer (1-4) aren't the ones I'm having. I'm starting to think it's JRE related or Force IDE plugin related.

I also downgraded to v34 of the Force.com IDE plugin and I still get the same error.

  • Have you used Mavensmate IDE?, easy to use and from my perspective even better than Eclipse. Take a look on this page: mavensmate.com – Yucel Jan 26 '16 at 15:12
1

Running it with the 'Eclipse IDE for Java Developers' is what's "strongly recommended", making Mars not the package of choice to use. See the Installation instructions for more on that. Officially, if you look at the release notes it does say "Eclipse Platform - Eclipse Juno (4.2) or later". I know they test it under Juno (Eclipse 4.2) and many report having run it fine under Keppler (Eclipse 4.3).

Beyond that, Known Issues are:

  1. To create a Force.com project against a Salesforce organization, the users must have profiles with the Customize Application and Modify All Data and permissions (typically held only by System Administrators).
  2. When adding a Force.com Nature to projects not created with the New Force.com Project wizard, the IDE's src folder may cause conflicts with other project directory structures containing src. If you have naming conflicts, either rename the non-Force.com folders so they are unique, or remove the Force.com Nature from the project.
  3. After changing the Apex Code log level marker under Force.com project properties, the IDE's user interface does not reflect the value change, even though the value is saved.
  4. When creating or refreshing a large Force.com project, the files will be populated in the background and might not be available immediately. To monitor the progress, show the Progress View by clicking Window > Show View > Other… then selecting General > Progress.
1

I had problem with "Eclipse Mars.1" with API 36 however its working fine on v35. I was getting below error on v36

Unable to update project properties: Element {urn:partner.soap.sforce.com}returnFieldDataTypes invalid at this location

I needed to downgrade it to "v35" and blogged here.

Same question asked on this thread and answered by Dan, which I followed.

  • Thanks. I did have this issue also and the question/answer you linked helped me solve it, but this isn't the problem I'm having now. – Swisher Sweet Jan 27 '16 at 20:39
0

To reveal all recent versions of the Force.com IDE, uncheck the "show latest" box. This is critical when sandbox instances are upgraded to the next seasonal release, but production and developer editions are not yet. There are new WSDL's for version + 1 that are not always compatible with the previous API.

Show all versions

0

Cannot complete the install because one or more required items could not be found. Software being installed: Force.com IDE 36.0.0.201601221512 (com.salesforce.ide.feature.feature.group 36.0.0.201601221512) Missing requirement: Force.com IDE 36.0.0.201601221512 (com.salesforce.ide.feature.feature.group 36.0.0.201601221512) requires 'org.apache.xerces 2.9.0' but it could not be found

Note : I am usinng Kepler SR2 4.3 version and while downloading Force.com plugin by using - http://media.developerforce.com/force-ide/eclipse42 I am getting above error. I am using java7 Please help me

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.