0

I'm using enterprise wsdl in .Net application to run sfdc webservices. Recently when I try to run the application I keep getting following error. Any idea how to avoid the issue?

System.Web.Services.Protocols.SoapException: UNSUPPORTED_API_VERSION: Invalid Api version specified on URL at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

Thanks, Lahiru

0

I was able to change the API version from app.config file. Was able to run the process after downgrading the API version

<applicationSettings>
    <SFServices.Properties.Settings>
        <setting name="SFServices_SFDC_ProdV2_SforceService" serializeAs="String">
            <value>https://login.salesforce.com/services/Soap/c/**31.0**/0DF40000000GsQU</value>
        </setting>
        <setting name="SFServices_servdev2_SforceService" serializeAs="String">
            <value>https://test.salesforce.com/services/Soap/c/**32.0**/0DFe00000004D49</value>
        </setting>
        <setting name="SFServices_staging_9_24_SforceService" serializeAs="String">
            <value>https://test.salesforce.com/services/Soap/c/**34.0**/0DF1900000000HH</value>
        </setting>
        <setting name="SFServices_na27_10_24_SforceService" serializeAs="String">
            <value>https://login.salesforce.com/services/Soap/c/**35.0**/0DF330000008TUB</value>
        </setting>
        <setting name="SFServices_FSB1_14_16_SforceService" serializeAs="String">
            <value>https://test.salesforce.com/services/Soap/c/**35.0**/0DF19000000CazJ</value>
        </setting>
        <setting name="SFServices_POC_1_14_SforceService" serializeAs="String">
            <value>https://test.salesforce.com/services/Soap/c/**35.0**/0DF560000008OSP</value>
        </setting>
    </SFServices.Properties.Settings>
</applicationSettings>
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.