2

We have a custom object "Quote". Whenever I go to any Quote record and try to navigate to some other record or home page, it gives me below error in lightning experience: enter image description here

I have tried with other custom objects and also with standard object but no issue is occurring for that. I also tried by removing the feed tracking for this object but still no success. The behavior I have noticed is that, if there will be any editable field on Layout, this error popup comes on UI. When I removed all of the fields from layout, this error popup didn't come.

I tried with the classic view and it's working fine there.

Can anyone please suggest what could be the issue in it ?

  • 1
    Sounds like platform bug to me – Mohith Shrivastava Jan 19 '16 at 9:29
  • I'd agree with Mohith. Sounds as though Lightning can't tell the difference between Quote and a Quote__c object, or something along those lines. I suggest you file a support case on the problem or else go to the Lightning Group on the Success Community if you can't get a support case opened on it. – crmprogdev Jan 19 '16 at 13:39
  • @crmprogdev API Name of the object is "Proposal__c" so I don't think it's related to standard Quote object in any case. But I am just surprised why this issue is occurring with only this object as there are a lot of custom objects in my org but all others are working fine. – S.Sharma Jan 19 '16 at 14:20
  • Seems I made an incorrect assumption based on the information you supplied. Again, I'd recommend you post this to the Success Community as the Lightning Experience in my view is still something of a beta that is going to have bugs. If you can file a case, that would be the ideal way to resolve it as clearly there's much more info needed than you've provided. – crmprogdev Jan 19 '16 at 15:11
0

Do you have the Name field on the page layout? I have found that removing that field caused the Unsaved Changes error to start occurring, and adding it back again resolved the problem.

I believe this is (or should be) a bug, but at least there seems to be a simple workaround to avoid it.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.