2

Got the following error when tried to deploy metadata via ant migration tool

Error: field integrity exception: unknown (required must not be specified)

enter image description here

Field metadata configuration is the following:

  <fields>
    <fullName>Description__c</fullName>
    <externalId>false</externalId>
    <label>Description</label>
    <length>1000</length>
    <trackTrending>false</trackTrending>
    <type>LongTextArea</type>
    <visibleLines>3</visibleLines>
  </fields>
3

Bit of an old question, but since there's no answer yet, I'll post my experience. I got the same message when I tried to deploy a field from sandbox A to sandbox B. The field was named Nationality__c, and at the beginning it was already present in both sandboxes as a required Text field. Then, in sandbox A, we changed the definition of the field to a picklist (which can not be required). Now, trying to deploy to sandbox B failed, with the mentioned error message.

The solution is to uncheck the "Required" checkbox on the existing field in sandbox B before deploying.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.