9

A newbie developer here... thx in advance for all your help!

I am trying to set up eclipse for salesforce. Keep getting this error on Eclipse Mars.1 and Eclipse Kelper.

[Unable to update project properties:

Element {urn:partner.soap.sforce.com}returnFieldDataTypes invalid at this location]

other info: Prior to this, I just setup github and imported project on Eclipse. I'm using Mac OSx el capitan version 10.11 Beta (15A279b) 64

Feel free to ask any Qs that might help fix the problem.

screen shot also attached enter image description here

  • tried on a different computer (PC and worked...) – Maddie Shang Jan 13 '16 at 22:44
15

The latest version of the Force.com IDE connects to API36, but most orgs are still on API 35. Uninstall the current version of the Force.com IDE in eclipse (look at the help/about menu for the about window that shows for installed software and lets you uninstall selected packages), then when you go to add new software uncheck the "show only latest versions" checkbox and install the API 35 version.

I just ran into this, and it resolved the issue for me.

Good luck

  • Thank you Kibitzer! Will try this and report back with results. – Maddie Shang Jan 14 '16 at 5:32
  • This happened to me when I tried to update the plugin when v35 came out. Had to do these exact steps back then. Thanks @kibitzer – nwillard Jan 18 '16 at 21:36
  • its good, it resolved my issue, – Riaz Muhammad Jan 20 '16 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.