2

We are not able to find EntitySubscription object in the partner developer org which is created in Partner org. This is the developer org we created using Environment Hub option. We are planning to list one of our app in AppExchange.

We already developed Apex classes in our free developer org which access and uses EntitySubscription object. But the above one does not. Any thoughts please?

Update: (added screenshot for the workbench) It does not have EntitySubscription Object.

enter image description here

  • Try using workbench to see if you can find it. I suspect you're not able to locate it using Eclipse or MavensMate, is that the case? I'm have a very difficult time myself at the moment retrieving metadata with the IDE's, but am able to find it via Workbench which tells me the problem is with the IDE's and not the org. – crmprogdev Jan 13 '16 at 14:59
  • Thanks @crmprogdev. But still does not find it in workbench too. Please advice. Added screen shot of the dev workbench. – Bforce Jan 13 '16 at 15:23
  • 2
    Is Chatter enabled in the org? Do you have Feed Tracking enabled on any objects? – zachelrath Jan 13 '16 at 15:33
  • 1
    Thanks @zachelrath. I have enabled Chatter and now it is working fine. I am seeing EntitySubscription object. Can you please post this as an answer? – Bforce Jan 13 '16 at 16:12
3

You need to enable Chatter in the org in order for the EntitySubscription object to be available through the API.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.