3

I've encountered with an issue after Spring 16 release has been deployed. Basically I cannot do anything with my project in Eclipse (Kepler + latest available Force.com IDE), every time it just throws error that credentials are invalid. I've tried to re-create the project, but got same error.

Everything worked fine on Friday. And I know that credentials are valid, cause it allows to log in with them from the website.

Has anyone from the community encountered with similar problems ?

Any help or suggestions would be appreciated.

Thanks in advance for your help.

  • 1
    (A) Are you using a security token? (B) what does your login history say about the login attempts? (C) Have you made any recent changes to your Network Access settings? (D) What error message are you getting specifically? – sfdcfox Jan 10 '16 at 15:34
  • take a look at this: salesforce.stackexchange.com/questions/19366/… – cropredy Jan 10 '16 at 17:36
  • Can you verify that the credentials are working in another tool that authenticates in a similar way. Maybe the Data Loader? – Daniel Ballinger Jan 10 '16 at 21:40
  • To Daniel Ballinger: – wesaw Jan 11 '16 at 8:24
  • To Daniel Ballinger: doesn't work in latest Apex Data loader as well. Same with ant migration tool. Not sure, maybe it's worth mentioning that we are using custom domain, kinda my150internal--bwdev1.cs21.my.salesforce.com. But I've tried already different combinations of endpoint urls, and as I mentioned it worked on Friday (i.e. with Winter16 release). No changes at all from our side since that moment. – wesaw Jan 11 '16 at 8:32
0

I am having a similar issue since the spring 16 upgrade but with a nodejs worker meant to run on Heroku. After the upgrade I was receiving an invalid_grant authentication error. The way that we authenticate the app into Salesforce prior to the upgrade was when we called the authenticate method we passed in an objet consisting of the username, password and personal security token. This worked fine until Saturday morning. While testing this morning I discovered that if I removed the personal security token from the credentials object I was passing during authentication I am now able to log straight into Salesforce sandbox and create and process records with my app. Spring 16 must change something in the flow but in reading the release notes I do not see any changes that were made to the flow. Not sure if this solves the exact problem you hare having with the Eclipse IDE but it is worth investigating.

One thing that we had to do to make this work was to relax IP restrictions with second factor. Also works with Relaxed IP restrictions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.