2

I am trying to develop a feature, which is based on push notification support on S1 mobile, i.e. "Someone posts to a group you belong to". This group notification is not coming as Mobile push notification for me, I tried all of the following settings.

Please Note: Normal @mention push notifications are coming on time and correctly always.

Any suggestions would be helpful regarding the same.

Following are the settings, I tried in mobile and desktop.

This group push notification could be enabled by opening S1 mobile's left menu > settings > push notifications

enter image description here

Additionally per following suggestion in this Salesforce help article, I've changed group settings for emailing on every post. enter image description here

Following are the group settings for sending email notifications for each post: enter image description here

Apart from that Salesforce > Setup > Notifications > Salesforce1 Notifications is turned on for all possible actions (pic below)

enter image description here

Here are Android and App versions for reference

Salesforce App Version

Android Version

  • 1
    Do other S1 notifications work fine? – drakored Jan 8 '16 at 8:33
  • Yes remaining all normal @mention push notifications are coming pretty well. – Abhinav Gupta Jan 8 '16 at 8:35
  • 1
    I presume (from the screenshot) this is Android. Can you confirm the SF1 app version as well as your Android version? There was an update made on Play Store yesterday - play.google.com/store/apps/… – Gaurav Kheterpal Jan 8 '16 at 8:36
  • Thanks ! Added the pics of same @GauravKheterpal to the post. I am on latest version of the S1 App, and Android is little behind 5.x – Abhinav Gupta Jan 8 '16 at 8:51
  • 1
    Just wondering I have more options in my Salesforce1 setting then yours and don't have this 'Someone posts to a group you belong to". Version is same. – Ashwani Jan 8 '16 at 10:38
3

The status for this idea is 'PARTIAL DELIVERY' and I see the same issue reported on this in the comments so IMO, this may be broken.

enter image description here

However, the comments from Salesforce product management does state it is available.

FWIW, I just did a quick test on my Nexus and it did not pop a notification when someone else posted on the same Chatter group. I would recommend raising a support case to find out the status of what's going on here.

enter image description here

2

Got following response from Salesforce support, its a bug in some Salesforce environments. Please check response from support team below for more details:

I checked and we have a bug on this Push notifications on SF1. As this Bug is related that on few environments it is working and on few it is not. As this is a new feature which is added in SF1 and we are seeing many user cases on the similar types. We have Bug W-2890608 which was raised and investigation is going on. We do not have ETA on this. But still I am checking on this and would also update information very soon.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.