2

I am trying to deploy certain changes using destructive xml in workbench. I am getting the below error on deploy:

SOAP-ERROR: Parsing WSDL: Couldn't load from '/app/workbench/soapclient/sforce.340.metadata.wsdl' : failed to load external entity "/app/workbench/soapclient/sforce.340.metadata.wsdl"

This used to work in the past and I am not sure if this has anything to do with the API version. Can someone help ?

  • This is an issue for me at the moment too – Brad Thomas Jan 15 '16 at 19:19
  • 1
    did you try with a lower API version other than 34? That worked for me. – Pel Jan 15 '16 at 19:25
2

There is an issue for this in GitHub: SOAP Error on retrieve or deploy actions.

From the discussion it sounds like the problem might be intermitent and caching related.

I'd suggest posting your experience into that discussion.


As per @Pel's comment, reverting to API v33.0 in workbench avoids the problem.

| improve this answer | |
  • 1
    Thank you for your suggestion. As a workaround, I switched to version 33.0 while logging into workbench, deployed it and there were no errors. – Pel Jan 7 '16 at 20:29
  • @Pel. Glad you got it via a workaround. I've added that to the answer in case anyone else encounters it. – Daniel Ballinger Jan 7 '16 at 22:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.