1

(Kindly Note : I have tried every example available)

What I have : Report - Summary report on Cases using Standard Report Type - Cases.
Object - Custom object having fields similar to above report.

I want to create Analytical Snapshot for the above report.

Hi, I have a scenario where I need to map Case (standard object) Age, Open, Closed fields to custom object for Analytic Snapshots. I have a report shown below

enter image description here

This reports have fields such as Open, Closed and Age, for these fields I choose Age(number), Open and Closed(Checkbox) but only TL9000 Security Level and # minor count is visible when I do mapping. My Custom object is having "Enable Reports" and is Deployed. Custom object is given below:

enter image description here

My Reporting Snapshot is not showing any field to map.

enter image description here

enter image description here

Kindly let me know how can I find all the fields to map of Reports in Reporting Snapshots setting.

  • Are you sure you've got the right report selected? Can you show us the saved report and the report you have when you setup your Reporting Snapshot? – David Litton Dec 28 '15 at 14:26
2

The reason fields from your source Summary report are not be showing on the left side of the mapping dialog is that the report fields must be either:

  • One of the group by fields
  • A field that is summarized in some way (sum, avg, min, max)

TL9000 Security level is a group by field and Minor Count is summarized. That is why they appear.

An Analytic Snapshot on a summary report is snapping the summary rows, that is all

| improve this answer | |
  • Yes, after so much of hassle and head banging, I should say you are right. Another limitation of Salesforce? or we have some workaround for summary reports – Rohit Dec 29 '15 at 12:44
  • 1
    you could snapshot a tabular report and do the sums on the snapshotted rows in a subsequent report. As SFDC says, the feature is called 'Analytical' Snapshots and hence designed to do trending of 'analytical' == 'summary' data over time. – cropredy Dec 29 '15 at 16:07
3

This will usually happen when the report format of your source report is not correct. It needs to be a Tabular or Summary report (not a Matrix report) - make sure you are using the correct report format and it should be resolved.

| improve this answer | |
  • It is a Summary report. – Rohit Dec 28 '15 at 14:39
  • Interesting, do you see the mapping fields if you switch to a tabular report? – Gaurav Kheterpal Dec 28 '15 at 15:18
  • Yes I have tried the Tabular report. It only has Global Summary as expected and no other fields. I am trying custom report types but fields like Open is not present. – Rohit Dec 28 '15 at 15:39
0

The print screen about looks like a summary report so I do not think that it the issue.

I have had this issue in the past. I had to add the user object to the report type and then select it at the top of the snapshot mapping and then the fields showed up for mapping.

| improve this answer | |
  • It is based on Standard report type - Cases. – Rohit Dec 28 '15 at 14:52
  • I am trying custom report types but fields like Open is not present. How to fetch that. Any idea please. – Rohit Dec 28 '15 at 15:40
  • On the right hand side there is a way to add fields in a report type. Do you know what I am referring to? (I do not have the screen in front of me). You choose the object and add the fields. Is this not showing for you? – sf guest Dec 28 '15 at 15:49
  • Yes, it is not showing. I am aware of where you are pointing. I investigated Standard Case Report type - there is section Case Information and there I can have the field Open. But this section is not there as an Object in CRT or in any other way. Stuck at one point. – Rohit Dec 28 '15 at 16:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.