5

I recently upgraded my Cordova installation to 5.0.0 - now I'm trying to create project using forcedroid and getting the following error

Copying template files...
Project successfully created.
Fetching plugin "https://github.com/forcedotcom/SalesforceMobileSDK-CordovaPlugi
n" via git clone
Installing "com.salesforce" for android
Failed to install 'com.salesforce':CordovaError: Plugin doesn't support this pro
ject's cordova-android version. cordova-android: 3.6.4, failed version requireme
nt: 5.0.0

How do I resolve this issue? I want to use 5.0 to take advantage of the newer plugins.

7

This is actually a known issue with Mobile SDK 3.3 - it will NOT work with Cordova version 5.0 (only Cordova 4.x is supported).

If you have to use Cordova 5.0, please upgrade to the latest version of Mobile SDK - 4.0

This has been discussed here as well.

| improve this answer | |
  • thx for the link – user10740 Dec 26 '15 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.