0

I am using process builder flow on Opportunity Product. My requirement is if discount is > 30% then do update a status field on Opportunity Object. I used the below evaluation criteria in decision box. [OpportunityLineItem].Discount > 30 (and also tried [OpportunityLineItem].Discount > 0.3 ) And if the condition is passed, then i am doing an immediate action to update parent Opportunity record.i.e. Opportunity Status Field values to 'Approval Required'. In the debug logs i see flow is not passing the criteria to do an update. User updates the percentage value from VFP.

I see Discount is being updated on Opportunity Product from VFP as expected. If i change the criteria to [OpportunityLineItem].Discount > 0, then flow is working fine. Any guess why process builder flow is not working when discount is either >30 or 0.3?

1

This has happened in the past as well. For percentages I usually have to create a formula field and multiply it by 10,000 (100 X 100).

  • It worked, Thanks. But as discussed with salesforce, this is a temp fix. And spring 16 will have the actual fix. – Bharat Dec 29 '15 at 19:58
  • I'm not as convinced it will be fixed. I'm not sure who or what has the problem with percentages but the fact that it's been around for over a year in one fashion or another I'd be prepared to keep that workaround. It doesn't need to be an idea since it's a bug. Glad it worked! – user2451 Dec 30 '15 at 2:13
  • I knew its a bug, i did it as a temp fix. But will make changes once Spring 16 changes are in place. – Bharat Dec 30 '15 at 21:02
  • To add 1 more item to this. The % thing is a mess between Flow and Process Builder and now Custom Metadata. Today I was comparing % values between Flows and Custom Metadata and it flat out is inconsistent. 100% in SF record via Flow and 100% in Metadata. 100% = 100, 1.0, 100.0, 100.00. Some worked sometimes not others most time none worked. 84% to 84, 0.84, 84.0. Same. Moving away from % after all of these issues today and in the past. BTW log files show correct value of 0.84 for both variables...but still they don't match. – user2451 Dec 31 '15 at 1:42
  • Since I wrote this the Custom Metadata team said a fix is coming and its related to how percentages are handled in Java. Yes slightly different than original question but possible the Process Builder issue is same reason. – user2451 Jan 11 '16 at 3:13
0

Looks like this is issue in SF.. vote the idea

Please upvote the idea

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.