3

I haven't encountered this before: I have 2x Record Types (both confirmed Active) on a custom object and both are each assigned to a unique page layout. I double-checked that each page layout-to-Record Type assignment was correcly laid out along with the corresponding Security Profiles (this object has same layout for all user profiles).

When I try to create a new Custom Object record however, there is no 'Select [Custom Object] Record Type' picklist page, the user is immediately defaulted to the 'pre-Insert' Edit Record page.

This is frustratingly basic, is there something else I am overlooking that would cause me to be unable to first Select the Custom Object Record type?

3

1)Go to the personal settings and select Record type Selection and make sure you have unchecked the objects in the data types column . Please see below image .Also click on that to expand for proper view .

enter image description here

2)Also another cause can be your profile does not have access to the other record types .Go to Profiles | record type settings | Select the Object | Edit to fix the same

enter image description here

  • 1
    Thanks for the response!! The 2nd Option did the trick! Weird, never had to use this before.. – GPP Dec 19 '15 at 9:04
  • 1
    Please mark as answered . – Mohith Shrivastava Dec 19 '15 at 9:05
  • 1
    Right ahead of you there ;-) – GPP Dec 19 '15 at 9:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.