0

I am using Salesforce Tabs + Visualforce. I am following the below steps

  • Created Site.com page
  • Clicking on Community Builder

It is giving error

enter image description here

And when i added the default login page as home page in configuration settings it is showing up in community builder. I don't no where I am doing mistake Can anyone help me with this.

1

in Site.com studio, you need to assign a home page through your site configuration:

enter image description here

hence the error "We cant find a valid home page for this community..."

the page needs to be a valid site page (all valid site pages will appear in the dropdown for selecting the pages under default pages)

0

Try going to Setup > Communities > All Communities, and click Manage next to the community you're building. From there, go to Administration > Pages, then click "Go to Site.com Studio" (screenshot below).

Go to Site.com Studio

  • I did the above steps but it is giving same error – Anjali Dec 14 '15 at 16:20
  • Sounds like maybe it's a bug. Have you tried creating a new community? And have you logged a case with Salesforce Support? – Marty C. Dec 15 '15 at 14:30
  • When I used Napili Template i was able to go to the community builder. But anyhow now i am not using community builder instead building a new Vf page – Anjali Dec 15 '15 at 20:38
  • You need to click on the force.com link on the left in the image. You can select a homepage from there. – TemporaryFix May 26 '17 at 13:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.