2

I'm doing work in an org's sandbox where we're not able to retrieve all of the org's metadata using either Eclipse or MavensMate. We've refreshed the sandbox and still have the same problem.

I've also attempted retrieving the metadata using different machines and others have tried as well. I've tried different versions of Java, finally leaving it at jdk1.0.0_79; the one I understand that's recommended. I've set the Java path in the eclipse ini file and on my machines as well. I've done separate installs of Eclipse, all with "no joy".

With all that said, I just finished using Workbench and was able to access the metadata objects that we're not able to access using the IDE's!!! What's up with that?

My Eclipse Force.Ide log gives me messages like the ones below for each of the metadata types it can't retrieve:

WARN [2015-12-07 08:23:53,636] (ComponentFactory.java:getComponentBean:1149) - Unable to get component for id 'SharingRules': Unable to get bean for id 'SharingRules'

Additionally, I've seen this message:

ERROR [2015-12-07 16:44:16,417] (MetadataOperationsRetryAspect.java:metadataOperationsRetry:34) - ForceRemoteException occurred while attempting to perform a metadata operation

which immediately precedes the error message that follows, which has me totally stumped (it continues ad infinitum beyond what you'd want me to post):

java.io.IOException: The system cannot find the path specified at java.io.WinNTFileSystem.createFileExclusively(Native Method) at java.io.File.createNewFile(File.java:1006) at com.salesforce.ide.core.internal.utils.Utils.saveDocument(Utils.java:770) at com.salesforce.ide.ui.packagemanifest.PackageManifestController.updateCacheWork(PackageManifestController.java:416) at com.salesforce.ide.ui.packagemanifest.PackageManifestController$1.run(PackageManifestController.java:291) at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:464) at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:372) at org.eclipse.jface.dialogs.ProgressMonitorDialog.run(ProgressMonitorDialog.java:507) at org.eclipse.ui.internal.progress.ProgressMonitorJobsDialog.run(ProgressMonitorJobsDialog.java:275)

What's so odd is that I'm not the only one who can't access all of the metadata, so it's not isolated to my machine. Oh, and I get a screen like what's below in Eclipse warning me about Package Manifest Content every time I try to retrieve metadata or set up a new project:

Package Manifest Content Warning

Any suggestions on how we can fix this?

  • I was informed (disclaimer - not validated by anyone affiliated with Salesforce) that this was a current issue with the Metadata API itself - the client I'm currently working with doesn't include SharingRules in version control because of this (along with a handful of other metadata types) – Brian Mansfield Dec 10 '15 at 19:36
  • Arrggh! I don't really want to hear that Brian. LOL! Do others get these kinds of errors when they try to start a new project? I'm even seeing this error message in my own dev org since updating to API 35. MavensMate won't even create a project for me in the above mentioned sandbox that I can open! But, it's a pain to get configured properly to begin with.(sigh) – crmprogdev Dec 10 '15 at 19:51
  • I'm getting the same error, did you figure out a way? – cartman Jun 13 '16 at 17:27
  • @cartman Client wound up filing a case with Salesforce on it. I was subcontracting and was put on another assignment before it was resolved, so unfortunately, no I didn't. It appeared to me to be an org specific issue. – crmprogdev Jun 13 '16 at 18:34
  • 1
    I was able to make it work, I know the solution doesn't make any sense but adding <mkdir dir="retrieveUnpackaged"/> after target did it. Hopefully someone will find this helpful ;) – cartman Jun 13 '16 at 19:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.